[ 追記:Visio2021ご利用環境について ]
本件はVisio2021でも同様の状況が発生することを確認しております。
つきましては、Visio2019ご利用環境同様に以下【対処方法】をご参考頂きますようお願い致します。
※HGPscanServシリーズ Ver5.9.0以上をお使いの方が対象となります。
5.9.0より前のバージョンではVisio2019での変換は非対応ですので対象外です。
【事象】
Visio2019がインストール済みの環境で、Visio文書をサービス起動で変換できないことが判明しました。
特定の条件で変換している場合、以下のエラーとなり変換失敗します。
STATUS=14[MS文書データを変換できません(ファイルを確認して下さい)][Error:61 文書データの読み込みに失敗しました。]
※Word2019,Excel2019,PowerPoint2019では発生せず、正常に変換可能です。
【発生条件】
・Visio2019がインストールされており、Visio文書が関連付けされている
・Pscanをサービス起動してVisio文書を変換する
【原因】
Visio2019自体に問題があり、サービス起動時にエラーとなる事例が報告されておりました。
以下のフォーラムにて、マイクロソフト社にてVisio2019のプログラム修正が必要であることが判明していますが、
改善されるまではVisio2019を使ってサービス起動で変換できません。
また、Pscanのプログラム側でも対処不可能であるため、最新版へバージョンアップしても改善されません。
ご参考:MSユーザーフォーラム
VISIO 2019 faults when used in a Windows Service on Windows 10
https://social.technet.microsoft.com/Forums/office/en-US/2768ad34-8ce5-4988-abc1-0d51a05d3b08/visio-2019-faults-when-used-in-a-windows-service-on-windows-10?forum=visiogeneral
※フォーラムから削除されているため、現在リンク切れです。
【対処方法】
Pscan画面から監視開始してください。
スタートアップに登録することで、ログイン時に自動的に監視開始することもできます。
設定手順は管理者マニュアルの以下の項目をご確認ください。
13(or14) FAQ >
13(or14).8 起動時・その他 >
13(or14).8.2 アプリケーション起動による監視をログイン時に自動でスタートする方法